Kahr Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
I purchased a CW45 in early October of this year. After putting 40-45 rounds through it, I disassembled and cleaned it after returning from the range. After reassembly and attempting a functionality check, I could not pull the slide to the rear. I noticed there was a bigger gap between the front of the slide and the frame, than between the rear of the slide and the frame. When I pushed down slightly on the muzzle end of the slide I was able to rack the slide. After closer inspection I determined the two lower frame rails in the front of the frame do not extend far enough to engage the grooves in the guide rod lug on the slide. With the slide all the way forward I can lift up slightly on the slide. If I push down on the muzzle end of the slide and pull the slide back (less than 1/16th of an inch) the slide racks normally, there is an even frame/slide gap and I can't lift the slide away from the frame. I have a CW40 also and I can't lift the slide away from the frame and the frame/slide gap is even along the length of the slide with the slide full forward.
Returned to Kahr and was very pleased/satisfied with their service. Thanks Kahr Arms!
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3 (Edited)
Howdy!! I've had no problems with assembly/disassembly. I haven't done anything to the weapon other than shoot/disassemble/clean/reassemble. Have you heard of any similar problems?? The inability to rack the slide without pushing down slightly on the muzzle end occurs about 50% of the time. Appreciate the response.
 
1 - 4 of 4 Posts
Top